Archive for April, 2014

Heartbleed Bug – Update

Wednesday, April 16th, 2014

For our users that haven’t been in touch with us or reading the latest reports on the serious encryption flaw known as the Heartbleed bug, we are listing some up-to-date information regarding the sites that have been affected. Most of the sites are ones that users frequent the most (e.g., Facebook, Instagram, Google, Yahoo), so passwords absolutely must be changed. We really recommend that you change passwords on all frequented sites.

Mashable has a comprehensive (and updated as of 4/15/14) list of affected sites here. For more information on the history of the Heartbleed bug, read the Sydney Morning Herald article here.

As always, if you have any questions about passwords or security, please don’t hesitate to set up an appointment with one of our senior-level Apple certified techs.


NeedMacHelp.com on Twitter